Simple visibility bug

Feb 15, 2010 at 11:58 PM
Edited Feb 15, 2010 at 11:59 PM

Today I noticed a little bug.

I set the visibility to skip on some nodes (this was done using a lookup table although it doesn't matter where the value came from). Then when I hid those nodes using the text filter from the table (the little triangle next to the header). When I refreshed the graph the nodes appeared. I unchecked it and refreshed graph and the nodes disappeared like they should.


Feb 16, 2010 at 12:45 AM
Edited Feb 16, 2010 at 12:59 AM

That's by design.  When you hid the row that contains the "Skip" cell, you hid the "Skip" cell itself.  NodeXL does not read any table rows that are hidden via Excel's table filters, and thus doesn't know that it's supposed to skip anything.  (It does display the vertex, because it's part of an edge, but it doesn't customize the vertex in any way because the row in the Vertices table that specifies its customizations is hidden.)

-- Tony