Calculating graph metrics for subgraphs

Jun 15 at 5:15 AM
I would like to create subgraph image for each node with level (k)=2. I would also like to estimate graph metrics (degree and betweenness) for each node of subgraph with level (k)=2. I have 34 vertices in total. Here, I am using an undirected graph. Network analysis from NodeXL is generating subgraph for each vertex. However, it is always estimating degree and betweenness for level (k)=1 instead of k=2. Could you please tell me what the problem is. I have 8 GB RAM on my PC.
I appreciate your help.
Coordinator
Jun 18 at 6:54 PM
Edited Jun 18 at 6:55 PM
Hello!

Thank you for the interest in NodeXL!

You can control the configuration of the Subgraph Images via the NodeXL>Analysis>Subgraph Images dialog:

Image

Graph Metrics, however, are calculated only for the Network as a whole (graph), each group, and each vertex (individual).

To select a subgraph, you may want to use the right-click menu operation: Select Adjacent Vertices (or just double click a vertex to select it, double-click again to select its neighbors, repeat as far as you like).

When selected, you could invert the selection and set the remaining vertices (right click to access Edit Selected Vertex Properties -- or use CTRL+P) by setting their "Visibility" to SKIP. Any vertex (or edge) with a Visibility set to "SKIP" will be ignored in the calculations and visualization.

You could repeat this process for each 2-degree neighborhood around each vertex and recalculate metrics after each sub-graph selection.

Regards,

Marc
Marked as answer by MarcSmith on 7/5/2016 at 7:04 PM
Jun 19 at 8:23 PM
Hi Marc,

Thank you very much for your reply. As you said, I selected a subgraph of a vertex by double clicking a vertex. I was not able to set the remaining vertices to skip. If I use "Visibility" to "Skip" in "Edit Selected Vertex Properties", the subgraph that I have already selected has been skipped as opposed to skipping the remaining vertices. Could you please tell me how I would skip the remaining vertices.

Regards,
Suchismita
Coordinator
Jun 19 at 8:38 PM
To resolve this issue you may need to invert the selection.

These steps may achieve the goal you seek:

Click the "ego" vertex.
Double-click it to select its neighbors.
Double-click it again to select its neighbor's neighbors.
Right-click>Select "Toggle Selection" (Or CTRL+T)
Right-click again to Edit Selected Vertex Properties and modify the Visibility setting to "SKIP".
Recalculate network metrics.

To reset to select the next vertex, we must first return all vertices to the "SHOW" Visibility.

The Visibility column can be found on the Vertices worksheet (to reveal this column, you may need to select NodeXL>Show/Hide>Worksheet Columns>Visual Properties).

Change all Visibility column cells to SHOW.

Refresh Graph. Repeat.

Regards,

Marc
Jun 20 at 3:53 PM
Hi Marc,

Thank you so much. It is very helpful.

Best regards,
Suchismita