No such emails were found

Jun 3, 2014 at 6:32 PM
I have installed NodeXL and want to analyze a subset of email on an exchange server. I choose the Import option from the NodeXL ribbon and From email network... I have tried the Analyze filtered email only option and the Analyze all emails option -- both give me the same error: No such emails were found. I have tried pointing it to a folder with the .pst file in it and it doesn't seem to find the file. What can I do to get it to connect to my email file??
Jun 3, 2014 at 6:42 PM

Thanks for the interest in NodeXL!

You may want to work with this Exchange Email server importer:

The email importer that ships with NodeXL is designed to talk to the local Windows Search Index which can collect any email stored locally on the machine.

You may not have email stored locally, or if there is email on the system, the Windows Index may not have be set to collect and index that pst file.

The Exchange Spigot for NodeXL connects directly to an Exchange server to collect data about connections in your email.


Jun 3, 2014 at 7:03 PM

​what do I do with the files? I clicked on the link you give below and then the Download button. It creates 2 dll files but doesn't tell me where to put them or what to do with them...

Jun 3, 2014 at 7:25 PM
See "Using third-party graph data importers in NodeXL Excel Template 2014" at .
Jun 3, 2014 at 7:30 PM
Which version of NodeXL are you running.

If you are up to date with the 300 series of NodeXL releases then you can place these dll files anywhere you like and tell NodeXL where you put them using the NodeXL>Data>Import>Import Options dialog:

  • If you use third-party graph data importers, such as the Social Network Importer for NodeXL, note that the folder where the importers are stored must be specified in the NodeXL>Data>Import>Import Options dialog:2014-NodeXL-Data-Import-Import Options-Data Importers
Jun 3, 2014 at 7:37 PM
I downloaded the version today so it is the latest. I followed the instructions "Using third-party ..." and it says: In NodeXL Excel Template 2014, go to NodeXL, Data, Import, Import Options in the Excel ribbon. --- I don't have any "Import Options" option on the Import dropdown in the NodeXL tab.
Jun 3, 2014 at 7:49 PM
When you click NodeXL, Data, Import, a drop-down menu should appear. What is the last item on that menu?
Jun 3, 2014 at 7:51 PM
Convert Old Workbook...
Jun 3, 2014 at 7:56 PM
That's an old version. Please uninstall it:

...and then install the latest version:

-- Tony
Jun 3, 2014 at 7:59 PM

​That is where we got this version this morning.

Jun 3, 2014 at 8:50 PM
This link:

...will take you to a page called "NodeXL Excel Template 2014". The "Recommended Download" on that page will download a file called NodeXLExcelTemplate2014Setup.exe, and that file will install the latest version.

Might you instead have found yourself on this page:

...and downloaded a file called If so, then that is an old version, and that's what I want you to uninstall before you install the latest version.

To find out if that is indeed what happened, please go to NodeXL, Help, About. An "About NodeXL" dialog box will open, and in that dialog box will be a version number. If it says "Version", then that's what happened.

I suspect this is the case, because there is no "Convert Old Workbook" option in the latest version.

-- Tony
Jun 3, 2014 at 8:53 PM
I forgot to mention that if you have the latest version (as of today), the version number in the "About NodeXL" dialog box should be

-- Tony
Jun 3, 2014 at 8:57 PM
No. That is the location and file name.

Jun 3, 2014 at 8:57 PM
I just looked through our release history, and "Convert Old Workbook" hasn't been in a NodeXL release in over four years. I'm very curious about what it is that you installed.

-- Tony
Jun 3, 2014 at 8:58 PM
What version number appears in NodeXL, Help, About?
Jun 4, 2014 at 2:09 PM

We removed everything and reinstalled and it seems to work now. Apparently the HelpDesk staff went out and found an "installer" at one point in the process. Perhaps that's where the older version was introduced? Not sure. At any rate, it is working now.

Jun 4, 2014 at 4:22 PM
I think what happened is that there was a very old version of NodeXL on your computer that you didn't know about. Once the help desk uninstalled it and installed the latest version, the problem was solved.

-- Tony