Install problem: XML expansion pack/smart doc missing and no NodeXL tab

Oct 11, 2013 at 3:29 PM
I tried to install on a win7, 64, excel 2010 system. The install seemed to work ok (no errors).

If I bring up the NodeXL Graph1 template I do not find the NodeXL tab. Template looks ok, but nothing to enable NodeXL.

If I try existing sample files such as serious_eats or senate_raw, excel gives me the xml expansion pack/smart doc missing.

Both cases there is no NodeXL tab.

I tried looking at "options" to configure the ribbon, but did not find anything that would allow me to add the tab.


Oct 11, 2013 at 4:10 PM

Something in Excel is preventing NodeXL from loading properly when you open the NodeXL template file. (When you select "NodeXL Excel Template" from the Windows start menu, you are opening the NodeXL template file.) I don't know what it is, but one thing you might try is to start Excel in what's called "safe mode," and then open the NodeXL template file while in safe mode. In safe mode, Excel skips a bunch of startup steps, one of which may be causing the problem.

Safe mode is described in "Work with Office safe modes" at, but you can cut to the chase by following these steps:

1) Click Start, point to All Programs, and then point to Microsoft Office.

2) Press and hold the CTRL key, and then click Microsoft Office Excel 2010. (I think that's the name you'll see.)

3) In Excel, manually open the NodeXL template file, which is called NodeXLGraph.xltx. It might appear in your list of recently used files, or you can find it in either "C:\Program Files\Social Media Research Foundation\NodeXL Excel Template" or "C:\Program Files (x86)\Social Media Research Foundation\NodeXL Excel Template", assuming you have an English computer.

Does that change anything?

-- Tony
Oct 11, 2013 at 4:48 PM

Thanks. That seems to work. I now get a side bar that lets me make graphs. I tried the Senate file and it generates something reasonable in safe mode.

Any ideas on what might cause this?

Oct 11, 2013 at 7:07 PM
Edited Oct 11, 2013 at 7:22 PM

One possibility is that you have an Excel add-in that is causing problems. You could try disabling all your add-ins before starting NodeXL normally. (By normally I mean not in the safe mode you just used.) If NodeXL works properly, then you know it's an add-in problem. You could then re-enable the add-ins one by one to determine which one is the culprit.

Disabling add-ins is discussed here:

If disabling a particular add-in solves your problem, please let me know. That way I can advise other people who run into the same annoying roadblock.