Missing vertices when I group by cluster

Jul 17, 2012 at 10:40 AM

I first encountered NodeXL as a TA for Nosh Contractor at Northwestern. Marc Smith introduced the project and made it available to our students. Since then, I've been using it in my own teaching and research and wanted to commend all of you on a great product.

I'm working on a research project and have a question about missing vertices when I group by cluster. I have a network of 305 nodes, but when I group by cluster the Group Vertices tab only includes 300 nodes. Do you know why this would occur?

Related, I'm considering defining Edge Visibility by Edge Weight to offer a more conservative network. However, I noticed that when I do this the number of nodes that show up in the Group Vertices tab is even lower. Does the Group by Cluster function only account for nodes that have visible edges? If so, does that mean the 5 missing nodes above simply don't have any edges and that's why they don't show up?



Jul 17, 2012 at 4:55 PM
Edited Jul 17, 2012 at 4:55 PM

Hello, Tom:

I'm glad you've found NodeXL useful.

It's not quite accurate to say that Group by Cluster accounts only for vertices that have visible edges.  The correct statement is that Group by Cluster accounts only for vertices that are part of the graph.  When you notice that the Group Vertices tab only includes 300 vertices, I bet it's because the graph has only 300 vertices.  You can confirm this by going to NodeXL, Analysis, Graph Metrics; selecting Overall Metrics in the Graph Metrics dialog box; and then looking at the Vertices count on the Overall Metrics worksheet.

So where did your missing vertices go?  One possibility is that you are setting the Visibility of one or more edge rows to Skip, and that results in one or more vertices not being connected to any edges.  In other words, those vertices become isolates.  NodeXL's default behavior is to skip vertices that are not connected to any edges, so they are not included in the graph and they cannot become part of a group.

Another possibility is that some vertices were isolates even before you changed any edge Visibilities.  If you manually add a vertex to the Vertices worksheet and it is not included in any edges on the Edges worksheet--in other words, you add an isolate--you have to set the Visibility of the vertex to Show to get it to become part of the graph.  Again, the default behavior is to skip a vertex that is not connected to any edges.  Setting the Visibility of the vertex to Show overrides this.

That leads me to the likely solution for the problem you are seeing.  If you want all your vertices to remain in the graph even if they start out as isolates or become isolates as the result of skipping edges, then set the Visibility of every vertex to Show.

At the risk of complicating things further, note that the Visibility options for both edges and vertices include "Hide."  When you hide an edge or vertex, it is still part of the graph but just isn't visible in the graph pane.  Hidden vertices can be grouped.

Hovering over the Visibility column header on either worksheet will pop up an explanation of all the options.

-- Tony

Jul 24, 2012 at 6:31 PM

Thanks, Tony. This is very helpful. I really appreciate your help.