XML-based non-European language search

Mar 5, 2012 at 1:06 PM
Edited Mar 5, 2012 at 1:07 PM

Hi I'm trying to use auto task-scheduled XML files to collect Twitter data.

 

When I search for certain Korean words using the pull down menu, it works fine. BUT, when I use them in the XMLs, below just does NOT work.

 

<SearchTerm>홍길동</SearchTerm> 

or

<SearchTerm>"홍길동"</SearchTerm>

 

I can see it turns into some totally irrelevant word on the command window as the scheduled task starts. Normally, the command window will display any Korean characters as input.

 

Anybody experienced any similar issues? This happened on Windows 7 with Office/Excel 2007. The current language setting is Korean.

Mar 5, 2012 at 5:01 PM

You'll have to save your network configuration XML file in the UTF-8 encoding, using an editor that will embed byte-order marks in the file.  Do this:

1. Open your network configuration XML file in Windows Notepad.

2. In Notepad, select File, Save As.

3. In the Save As dialog box, set the Encoding (next to the dialog box's Save button in Windows 7) to UTF-8.

4. Select a file name and save the file.

The NodeXLNetworkServer program should now recognize your Korean words.

-- Tony

Mar 19, 2012 at 2:48 AM

Thanks a lot. That solved the problem. One of the XMLs I revised turns out saved as ANSI.