Error in Download

Jan 21 at 2:38 PM
I have tired a few times to download NodeXL but each time I am getting an error during installation. I am conscious each time to delete any previous files but to no effect.

Any help or assistance would be very much appreciated.

The error details are as such:



Name: NodeXL Excel Template
From: http://www.nodexlgraphgallery.org/NodeXLBasicSetup/Smrf.NodeXL.ExcelTemplate.vsto

************** Exception Text **************
Microsoft.VisualStudio.Tools.Applications.Runtime.InvalidManifestException: Exception reading manifest from http://www.nodexlgraphgallery.org/NodeXLBasicSetup/Smrf.NodeXL.ExcelTemplate.vsto: the manifest may not be valid or the file could not be opened. ---> System.Net.WebException: The remote server returned an error: (407) Proxy Authentication Required.
at System.Net.HttpWebRequest.GetResponse()
at System.Xml.XmlDownloadManager.GetNonFileStream(Uri uri, ICredentials credentials, IWebProxy proxy, RequestCachePolicy cachePolicy)
at System.Xml.XmlDownloadManager.GetStream(Uri uri, ICredentials credentials, IWebProxy proxy, RequestCachePolicy cachePolicy)
at System.Xml.XmlUrlResolver.GetEntity(Uri absoluteUri, String role, Type ofObjectToReturn)
at System.Xml.XmlTextReaderImpl.OpenUrlDelegate(Object xmlResolver)
at System.Threading.CompressedStack.runTryCode(Object userData)
at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
at System.Threading.CompressedStack.Run(CompressedStack compressedStack, ContextCallback callback, Object state)
at System.Xml.XmlTextReaderImpl.OpenUrl()
at System.Xml.XmlTextReaderImpl.Read()
at System.Xml.XPath.XPathDocument.LoadFromReader(XmlReader reader, XmlSpace space)
at System.Xml.XPath.XPathDocument..ctor(String uri, XmlSpace space)
at System.Xml.XPath.XPathDocument..ctor(String uri)
at Microsoft.VisualStudio.Tools.Applications.ServerDocument.AddCustomization(String documentPath, Uri deploymentManifestUrl)
--- End of inner exception stack trace ---
at Microsoft.VisualStudio.Tools.Applications.ServerDocument.ThrowManifestException(String url, Exception inner)
at Microsoft.VisualStudio.Tools.Applications.ServerDocument.AddCustomization(String documentPath, Uri deploymentManifestUrl)
at Smrf.NodeXL.ExcelTemplatePostDeploymentAction.PostDeploymentAction.SetAssemblyLocationInTemplateFile(AddInPostDeploymentActionArgs args)
at Smrf.NodeXL.ExcelTemplatePostDeploymentAction.PostDeploymentAction.Execute(AddInPostDeploymentActionArgs args)
at Microsoft.VisualStudio.Tools.Applications.Deployment.PostDeploymentActionsHost.Execute(Int32& lastExecutedPostAction, Uri deployManifestUri, AddInInstallationStatus installStatus, String deployManifestXml, String appManifestXml, String hostManifestXml, String[] postActionDataXmls, String productName, String version, String applicationBase, String[] assemblyClassNames, String[] assemblyNames, String[] assemblyFullNames)
at Microsoft.VisualStudio.Tools.Applications.Deployment.PostDeploymentActionsHost.Execute(Int32& lastExecutedPostAction, Uri deployManifestUri, AddInInstallationStatus installStatus, String deployManifestXml, String appManifestXml, String hostManifestXml, String[] postActionDataXmls, String productName, String version, String applicationBase, String[] assemblyClassNames, String[] assemblyNames, String[] assemblyFullNames)
at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.InvokePostActions(Uri deploymentUri, AddInInstallationStatus installStatus, String deployManifestXml, String appManifestXml, ApplicationManifest manifest, String productName, String version, AppDomainSetup appDomainSetup)
at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.InstallAddIn()
Coordinator
Jan 21 at 11:37 PM
Hello,

it looks like you are using a proxy server to download NodeXL. ClickOnce doesn't like that. If you can, please disable the proxy settings just to download NodeXL and enable them again after download. If you can't do that, please take a look at this fix by Microsoft https://support.microsoft.com/en-us/kb/917952.

Regards,
Arber
Jan 26 at 9:16 AM
Hi Arber.

Thanks for your response. I have tried to adjust the proxy setting both myself and reaching out to out system administrator with no luck. Frustrating I can get it on my personal machine no bother...

I am struggling to use the hotfix that you have linked to. Is there any other way round this? I am very keen to use this plug as it, just struggling to access it on our system!

Thanks again for your support.
Coordinator
Jan 26 at 11:41 AM
Hello,

I will keep looking if I find something else and will keep you updated.

Regards,
Arber
Jan 26 at 11:47 AM
Thanks for the support!