License Issue with NodeXL Pro..

Oct 16, 2015 at 11:48 PM
I'm getting the same error that a few others have received: "you have reached the maximum number of offline opens" ?

You mentioned it's a firewall issue. How do we attempt to solve this? I'm getting the same error with my home network (Comcast) & my school network. Never had an issue with software licenses before. Like some others, I use in the classroom, so any expedited help would be much appreciated! Thanks.
Oct 17, 2015 at 3:28 AM
I am having exactly the same problem. I just received the licence, copied it onto my local drive but I get the "you've reached the maximum number of offline opens" message and then NodeXL just closes.
Coordinator
Oct 17, 2015 at 10:56 AM
Hello,

this error message means that NodeXL is not able to ping the server. Add an exception to your firewall for ICMP protocol (different firewalls have different settings so I suggest you search on the internet how to add an exception for ICMP in your firewall). If this doesn't succeed, please try disabling your firewall.

Regards,
Arber
Oct 17, 2015 at 12:16 PM
That does not seem to be the issue... I have set the ICMP as below (allowing everything related to it) and that makes no difference. I also shut the firewall down completely and it made no difference. Same error.

Image
Oct 17, 2015 at 2:27 PM
I'm getting the same error even without a firewall as well. I'm running Windows 8.1 Pro, Office 2013 if that helps at all.
Coordinator
Oct 17, 2015 at 3:14 PM
Hello,

please search in your firewall filters for ICMPv6 and check if that is allowed too (sometimes ping packets are sent through IPv6). If that doesn't help either please follow these steps to reset NodeXL:
  1. Copy your initial license (sent to you by e-mail) to a folder which doesn't contain OS sensitive data (you can use D: drive, My Documents etc)
  2. Go to C:\Users[user_profile_name]\AppData\Local\MicrosoftResearch\NodeXLExcel2007Template and delete openPro.dat and LicensePath.txt files.
  3. Open NodeXL and it should ask you to choose the license. Please select the path you used in step 1.
Hope this helps!

Regards,
Arber
Oct 17, 2015 at 7:58 PM
OK. So I got it to work on my home network (Comcast) by disabling the firewall. I thought I had done it before, but realized I didnt save the settings properly. However, the problem I have is I'm using NodeXL for my college class. Most/all of my students will be using the college firewall. How realistic is it for me to ask our school's CIO to lower the college's network security settings to allow the license to work? Similarly, I have corporate clients as well? What do I tell them?
Oct 17, 2015 at 8:13 PM
I just tried all of that. It looked for the new license file, but then gave the same error. There was no openPro.dat file (only the LicensePath.txt file). I'm not sure if that is part of the issue?
Coordinator
Oct 17, 2015 at 9:02 PM
Hello,

you can ask the network administrator to allow ICMP and ICMPv6 and there is no need to disable the firewall.

regards,
Arber
Coordinator
Oct 17, 2015 at 9:03 PM
Hello,

are you sure it is the same error? If it is the same then the ONLY reason is that the firewall is blocking NodeXL.

Regards,
Arber
Oct 17, 2015 at 9:37 PM
Definitely the same error. "Your have matched the maximum number of allowed offline opens!"... I have looked in both the Kaspersky and Windows Firewalls and opened up all of the ICMP, ICMPv6 (and ICMPv4 just to be safe) settings that I could find. I also just turned both the Kaspersky and Windows Firewalls off and followed all of the steps above. Still getting the same error. As mentioned above, there was no openPro.dat file when I looked in the directory that houses the license location. Should there be one there and any reason why it is not getting created?
Coordinator
Oct 19, 2015 at 4:38 PM
Edited Oct 19, 2015 at 4:38 PM
Hello,

the openPro.dat file is created the first time NodeXL validates the license through the server. Since NodeXL can not communicate with the server, the file does not get created. Are you on a lab/office environment or home? If you want we can schedule a TeamViewer session.

Contact me at arberceni@smrfoundation.org

Regards,
Arber
Oct 21, 2015 at 2:34 AM
Edited Oct 21, 2015 at 2:37 AM
I got the same error. "You have reached the maximum allowed number of offline opens!" I opned all ICMPv6 in my firewalls. And deleted License path and tried again but same error occured. There was not OpenPro.dat file in 'NodeXLExcel2007 Template' folder. I use Windows 10.
Coordinator
Oct 21, 2015 at 3:05 PM
kiara0228:

can you please turn off all your firewalls and try again?

Regards,
Arber