Problem importing from Twitter

Aug 22, 2015 at 9:12 AM

I've just started using NodeXL. When I import data from a Twitter user, it's happened twice that the program is importing for several hours, but when it stops, my spreadsheet is still empty.

Hopefully someone knows how to fix this/what I'm doing wrong.


Aug 22, 2015 at 4:24 PM

Thank you for the interest in NodeXL!

You may want to try the Twitter Search Network Importer using the user's name instead.

The Twitter Users Network Importer is really focused on LISTS of users. You may either past a list of usernames OR point to a Twitter/List to select users.

The use of the Twitter Users Network Importer with one user will just result in a single vertex.

You can run this with a single vertex IF you also deselect the "Import only the Twitter users I am interested in" option. In this case, NodeXL will import a list of everyone the target user mentioned or replied to.

You can then rerun the Twitter Users Network Importer with the new set of associated user names. So this becomes a two-step process.

Hope that helps! Feel free to reply for follow-up!


Aug 31, 2015 at 12:39 PM
Hey Marc,

I've succeeded in importing the data.

Thank you!


Dec 9, 2015 at 11:09 AM
Hi MarcSmith,

Sorry to jump on the end of this thread but I'm having problems pulling in any data when using 'Import from Twitter Users Network' with a list of Twitter users.

I set it running over night and have come back to the office to find it hasn't pulled any data at all. It's a completely blank sheet.

In the last couple of days I've also had problems with calculating Graph Metrics in previously run documents. It seems to get stuck half way through calculating and doesn't progress which means we can't generate a map from the data.

These two issues have only started occurring since the last NodeXL update.

I've removed and reinstalled NodeXL too but this hasn't resolved the problems.

Any help gratefully received.

Dec 9, 2015 at 4:56 PM
Hello Vicky,

do you get any error message when importing from Twitter or calculating Graph Metrics? If so please send a screenshot.

Dec 9, 2015 at 5:24 PM
No problem importing from Twitter, took a day to import all data but it worked. After that, I run a graph of the 167k imported tweets and worked well. NodeXL made the graph Problem started after I run Graph Metrics, select all option... BUT only on Harel.
Em 2015-12-09 14:56, arber escreveu:
Dec 9, 2015 at 5:37 PM

Hi Arber,

I don’t get any error messages but it just gets stuck here when calculating metrics every time:

Vicky Green
Team Coordinator
+44 20 7260 2700

Blue Rubicon is a Teneo Company.

This email is intended only for the addressee named above. It may contain confidential or legally privileged information. If you are not the named addressee, or the person responsible for delivering the message to the named addressee, please destroy this email and notify the sender immediately. Its contents must not be disclosed to any other person, nor should copies be taken. Blue Rubicon (Holdings) Limited is registered at 6th Floor, 6 More London Place, London SE1 2DA. Company number 08210694.

Dec 10, 2015 at 6:21 PM

I don't see any image attached, I think CodePlex doesn't accept them.

Can you please use some other service to upload the images (Dropbox, Google Drive etc)?