Error installing NodeXL on Windows 8 64 bit with office 2013

Dec 17, 2013 at 10:12 AM
Installing using command 'C:\Users\Tony\AppData\Local\Temp\VSD6449.tmp\VSTOR30\vstor30.exe' and parameters ' /q:a /c:"install /q /l"'
Process exited with code -1073740777
Status of package 'Visual Studio Tools for the Office system 3.0 Runtime Service Pack 1' after install is 'InstallFailed'

I also tried downloaded the "vstor30sp1-KB949258-x86.exe" from Microsoft and run it, and I have the following Error message:
"None of the products that are addressed by this software update are installed on this computer. Click Cancel to exit setup."

It look like the "vstor30sp1-KB949258-x86.exe" is for office 2007, I am use office 2013. Do I need to install other server pack for office 2013 instead? or Does NODEXL works with office 2013?

Tony.
Dec 17, 2013 at 6:07 PM
Edited Dec 17, 2013 at 6:07 PM
Hello, Tony:

Yes, it's supposed to work with Office 2013. I just took a new computer (a virtual machine, actually), installed Office 2013 on it, and then installed NodeXL version 1.0.1.245, all without a hitch.

Yours isn't the first problem report we've seen about this, however, and I haven't yet figured out why problems sometimes occur with Office 2013.

Please try double-clicking the file called "DoNotUseThis.msi" instead of "Setup.exe". That will bypass the "Visual Studio Tools for the Office" stuff, which you don't actually need because Office 2013 comes with its own version. Let me know what happens.

Thanks,
Tony
Dec 19, 2013 at 7:02 PM
Hello Tony,

Thanks for the reply, I have tried what you suggested, and I have the following Error message:
"Error 1001. Access to path "C\Program Files(x86)\Social Media Research Foundation\NodeXL Excel Template\smrl.NodeXL Execl
TempatesSetupClickOnceInstaller.InstallState' is denied.

I am using Window 8 profesional instead of normal Window 8.
Dec 20, 2013 at 6:08 PM
Tony:

I just tried installing NodeXL version 1.0.1.245 on a Windows 8.1 Professional computer and it worked fine, so I don't think it's a Windows 8 vs. Windows 8 Professional issue.

Unfortunately, I don't know what the cause is. The exit code you mentioned, -1073740777, stands for "unknown software exception," which doesn't give you and me much useful information, to put it mildly.

The tests I've run have been on new Windows computers. Did you have an earlier version of Office installed on yours before you installed Office 2013? I'm wondering if that can cause problems.

By the way, we are in the middle of overhauling NodeXL's setup program to simplify it and (we hope) reduce the number of problems we have with it. It could very well fix this particular problem, because the new setup program does not install the "vstor30.exe" program that is causing grief in your case.

-- Tony
Dec 21, 2013 at 8:52 AM
Edited Dec 22, 2013 at 10:48 AM
Hi Tony,

Yes, I have both office 2010 and office 2013 on my computer, because when I instead office 2013, it asks me do I want to remove office 2010, I said no, just in case, I need it for some of my old excel sheets.

Please let me know when your new setup program has completed. I would like to try it. Thanks!

Tony.
Dec 23, 2013 at 11:00 PM
Oh, I've never tested that scenario. I can't be certain without trying it, but having two side-by-side versions of Office might be the cause of the problem.

I'll announce the new setup program as soon as it's ready, which should be sometime in January. Thank you for your patience.

-- Tony
Jan 6, 2014 at 2:18 PM
i was able to install NodeXl on windows 8 64bit/ office 2013 just fine. the problem that when i open the template it doesn't open the graph side window!
Jan 7, 2014 at 6:21 PM
aborham:

Did your computer have an earlier version of Office on it before you installed Office 2013? Also, please tell me which version of Office 2013 you have. You can tell by going to File, Account in the Excel ribbon. (For example, "Microsoft Office Professional Plus 2013".)

-- Tony
Jan 9, 2014 at 4:25 AM
Tony:
yes i previously had office 2010 installed before on windows vista and i'm running now Microsoft Office Professional Plus 2013 on windows 8