handling isolates in NodexXL

Jul 23, 2013 at 1:49 PM
Edited Jul 23, 2013 at 1:50 PM
Hi:

I have vertices (isolates and non isolates) already grouped. I have set the isolates to show, with size 1 and shape circle. I am grouping vertices in a box on the graph pane. But the graph shows all isolates as a seperate group. I want the isolates to show up in thier respective groups. what should I do. Thanks.
Jul 23, 2013 at 9:59 PM
Edited Jul 23, 2013 at 9:59 PM
How did you create your groups? If you used NodeXL, Analysis, Groups, Group by Cluster, then isolated vertices (those with no edges) and neighborless vertices (those that don't connect to other vertices) were not grouped with the graph's other vertices. The way they were grouped depends on the settings you selected in the Group by Cluster dialog box, but they never get mixed in with other groups. That's because the clustering algorithms work by analyzing the connections between vertices, and isolated and neighborless vertices have no such connections.

So when you say that you want the isolates to show up in their respective groups, I believe they are showing up in their respective groups; it's just that the vertices aren't grouped the way you want them to be grouped.

-- Tony
Jul 24, 2013 at 12:28 AM
Thanks Tony for the quick reply. I have a list of systems and they are all mapped to their departments ion which they reside. I had the departments in a separate column. I then grouped them by department and used the F-R chart type, group by vertex attribute (department) and then used layout options to lay them out in boxes by groups. at this point I had what I wanted. I had a bunch of isolates (systems with no edges and by default these were not rendered) in each department and I wanted to see if I can show them inside the department boxes. But Nodexl puts all isolates in a separate box as a group - it doesn't put it in the respective department boxes. I know that I may be not doing something correct. I did not even try the group by cluster.
Jul 24, 2013 at 1:01 AM
Edited Jul 24, 2013 at 1:02 AM
I see. Please ignore my comments about Group by Cluster, which I wrongly assumed that you are using. You are actually using Group by Vertex Attribute.

I think the problem is that your isolates did not get put into the department groups they belong in. They are in NO groups, and NodeXL places all ungrouped vertices in their own box. (It doesn't put all isolates in their own box; it puts all ungrouped vertices in their own box.)

If your isolates were not set to "Show" when you ran Group by Vertex Attribute, then NodeXL completely ignored the isolates and did not place them in groups. You set them to "Show" afterward and that caused them to appear in the graph pane, but they remained ungrouped.

The solution, then, is to run Group by Vertex Attribute again, while the isolates are set to Show. They will then be grouped properly, and they should appear in their correct department boxes in the graph pane.

-- Tony