Twofold question; Tracking retweets and "tweet date" format.

Jun 26, 2013 at 5:35 PM
Hi,

I am just starting learning NodeXL and i use it to analyse Twitter. I couldn't find a proper way to track retweet relationships.. is there any way to do it? I 've look the documentation and some examples from the gallery but i didn't really find anything useful.

Also there is no documentation for the "tweet date" format, could anyone enlighten on this?

Thanks in advance.
Jun 26, 2013 at 5:59 PM
On the date format question, Twitter-related dates are shown in UTC format, which is also known as GMT:

http://www.urbandictionary.com/define.php?term=UTC

When NodeXL tells you that a "Tweet Date (UTC)" is "6/19/2013 14:03", for example, it means that the tweet was tweeted on 6/19/2013 at 2:03 PM, London time.

This example is from an English computer. Computers running in a different language will display dates in the correct format for that language, but the actual dates will remain the same.

-- Tony
Jun 26, 2013 at 6:14 PM
Thanks for the answer Tony,

what i get for the time though is i.e. "41446.60157".. which might be the time that has elapsed since the time has been posted (not exactly sure though). The problem is, fetched tweets will be processed later on if i want to store them somewhere for post-processing. So now the problem is that i need to also know the time that i fetched them.. and it gets rather confusing. There is an Imported column for the imported tweets as well with a number of type '348084458219515904'...
Jun 26, 2013 at 6:39 PM
Let's discuss the format issue first.

Are you saying that the values in the "Tweet Date (UTC)" column on the Edges worksheet for the Twitter Search Network are showing up as numbers instead of dates? On an English computer, the values should look like "6/19/2013 14:03", for example.

-- Tony
Jun 26, 2013 at 6:44 PM
tcap479 wrote:
Let's discuss the format issue first.

Are you saying that the values in the "Tweet Date (UTC)" column on the Edges worksheet for the Twitter Search Network are showing up as numbers instead of dates? On an English computer, the values should look like "6/19/2013 14:03", for example.

-- Tony
Exactly, i was expecting something like the example you gave (6/19/2013 14:03).
Jun 27, 2013 at 12:12 AM
Edited Jun 27, 2013 at 12:13 AM
I believe you have configured Excel to show formulas instead of values in your cells. See this post for instructions on how to fix the problem:

http://www.lytebyte.com/2008/04/10/how-to-view-formulas-instead-of-values-in-excel-cells/

You want to do the opposite of the instructions in the post--namely, you want to turn formulas OFF.

-- Tony
Jun 27, 2013 at 8:54 AM
Edited Jun 27, 2013 at 8:56 AM
tcap479 wrote:
I believe you have configured Excel to show formulas instead of values in your cells. See this post for instructions on how to fix the problem:

http://www.lytebyte.com/2008/04/10/how-to-view-formulas-instead-of-values-in-excel-cells/

You want to do the opposite of the instructions in the post--namely, you want to turn formulas OFF.

-- Tony
I did that and i also manually checked it but no formulas are showing, thus there is nothing being applied to that column. This format was probably the way it meant to be?

I don't know if this is related to my problem but i am running Excel from a OSX and though Parallel Desktops as my virtualisation solution. I installed Excel and NodeXL but when i open Excel the NodeXL ribbon is missing. So what i did is basically, open the NodeXL template file which is in this path:

"C:\Program Files (x86)\Social Media Research Foundation\NodeXL Excel Template\NodeXLGraph.xltx"

Do you think that this might cause problems?
Jun 27, 2013 at 4:17 PM
Edited Jun 27, 2013 at 7:27 PM
No, that is not how dates were meant to be. On a U.S. English computer, the Twitter dates should look like "6/19/2013 14:03". Something is wrong on your computer.

Please do the following:
  1. Close all Excel windows.
  2. Open Excel. (Not NodeXL, just plain Excel.) In cell A1, paste "6/19/2013 14:03", without the quotes. What appears in the cell after you do the paste? (On my computer, "6/19/2013 14:03" appears in the cell.)
  3. In the Windows Start menu, enter "NodeXL". At the top of the search results you should see "NodeXL Excel Template." Click it, which will create a new NodeXL workbook in Excel. (That's the recommended way to start NodeXL.)
  4. On the Edges worksheet in the NodeXL workbook (the worksheet that appears when you create a NodeXL workbook), paste "6/19/2013 14:03" into cell N3. That's the first empty cell in the "Add Your Own Column Here" column. What appears in the cell after you do the paste? (On my computer, "6/19/2013 14:03" appears in the cell.)
-- Tony
Jun 29, 2013 at 10:57 AM
tcap479 wrote:
No, that is not how dates were meant to be. On a U.S. English computer, the Twitter dates should look like "6/19/2013 14:03". Something is wrong on your computer.

Please do the following:
  1. Close all Excel windows.
  2. Open Excel. (Not NodeXL, just plain Excel.) In cell A1, paste "6/19/2013 14:03", without the quotes. What appears in the cell after you do the paste? (On my computer, "6/19/2013 14:03" appears in the cell.)
  3. In the Windows Start menu, enter "NodeXL". At the top of the search results you should see "NodeXL Excel Template." Click it, which will create a new NodeXL workbook in Excel. (That's the recommended way to start NodeXL.)
  4. On the Edges worksheet in the NodeXL workbook (the worksheet that appears when you create a NodeXL workbook), paste "6/19/2013 14:03" into cell N3. That's the first empty cell in the "Add Your Own Column Here" column. What appears in the cell after you do the paste? (On my computer, "6/19/2013 14:03" appears in the cell.)
-- Tony
I did exactly as you said... and for both cases (2,4) "6/19/2013 14:03" appears, just as in your computer.
Jun 29, 2013 at 5:04 PM
Okay, good. Everything is as expected so far. One more experiment, please:
  1. Close all Excel windows.
  2. Create a NodeXL workbook. (In the Windows Start menu, enter "NodeXL". At the top of the search results you should see "NodeXL Excel Template." Click it.)
  3. In the Ribbon, select NodeXL, Data, Import, From Twitter Search Network.
  4. In the Import from Twitter Search Network dialog box, leave all settings at their default values and click OK. A bunch of data should get inserted into the Edges worksheet.
  5. What appears in cell P3 of the Edges worksheet? That's the first cell in the "Relationship Date (UTC)" column. (On my computer, "6/23/2013 4:11" appears in the cell.)
-- Tony