Cannot install Nodexl

Nov 18, 2012 at 12:57 AM


I tried to install nodel but always get the following error msg:

Component Visual Studio Tools for the Office system 3.0 Runtime Service Pack 1 has failed to install with the following error message:"This action is only valid for products that are currently installed. "
The following components failed to install:- Visual Studio Tools for the Office system 3.0 Runtime Service Pack 1
See the setup log file located at 'C:\Users\ISABEL~1\AppData\Local\Temp\VSDAF33.tmp\install.log' for more information.

I tried to look into the log file as instructed above, but cannot find this address. 

Can anyone let me know what the issue is and how I can get it running?

Thanks a lot. 

Nov 19, 2012 at 4:21 PM


This can occur when a piece of software that NodeXL needs has previously been uninstalled.  Due to a bug in that software's uninstaller, NodeXL is unable to reinstall the software, and you get the message you're seeing.  (For reference, the problem is described at

Unfortunately, the fix involves editing the Windows registry.  If you are comfortable editing the registry, or you can dump this task onto someone who is, the fix is described in the above reference.  I'll summarize the steps here:

1. Open RegEdit.

2. If you have a 64-bit version of Windows (which is what most recent computers have), navigate to the "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\vsto runtime Setup\v9.0.21022" key.  If you have a 32-bit version of windows, navigate to "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\vsto runtime Setup\v9.0.21022" instead.

3. Change the key's "Install" value from 1 to 0.

4. Close RegeEdit.

5. Run NodeXL's Setup.exe program again.

-- Tony