Installation Error, file not found error

Oct 14, 2012 at 5:32 PM


   I'm trying to install NodeXL but running into a problem.  Here's what I'm doing and the result:

- Run setup.exe

- Receive the following popup error:   Error 1001. The installation of the ClickOnce solution failed with exit code -400

- In opening the C:\Program Files (x86)\Social Media Research Foundation\NodeXL Excel Template\smrf.NodeXL.ExcelTemplate.vsto file (following the advice of some other discussion threats) I see the following stack trace.  Note that Excel is definitely closed when I try setup and I don't find any reference to it in Control Panel, Program Files.  Here is the stack trace:


Name: From: file:///C:/Program Files (x86)/Social Media Research Foundation/NodeXL Excel Template/Smrf.NodeXL.ExcelTemplate.vsto

************** Exception Text **************

System.IO.FileNotFoundException: The system cannot find the file specified. (Exception from HRESULT: 0x80070002)   

at System.Deployment.Internal.Isolation.IsolationInterop.GetUserStore(UInt32 Flags, IntPtr hToken, Guid& riid)   

at System.Deployment.Internal.Isolation.IsolationInterop.GetUserStore()   

at System.Deployment.Application.ComponentStore..ctor(ComponentStoreType storeType, SubscriptionStore subStore)



Also note that when I look under my profile for C:\Users\<username>\AppData\Local that I do not find an apps\2.0 directory.  Is my ClickOnce installation corrupted perhaps?  I appreciate any insight you all might have.




Oct 16, 2012 at 1:41 AM
Edited Oct 16, 2012 at 1:41 AM


First, I want to thank you for searching out and trying the answers you found elsewhere in this forum.  I'm sorry they didn't work for you.

Unfortunately, there is something wrong with the ClickOnce system on your computer that has nothing to do with NodeXL.  The "cannot find the file specified" message is not referring to a NodeXL file; it's referring to something in ClickOnce that keeps track of who you are.  (That's what the "GetUserStore" business is about.)

I was about to post a question on the Microsoft programmers' forum having to do with ClickOnce problems when I noticed that other people have already asked about this problem:

Here is one such post that included several possible solutions:

If you're feeling ambitious, you might try the solutions included there.  If you have any luck, please let me know.


Oct 16, 2012 at 1:46 AM

I didn't narrow down the search enough in my previous post.  Try this instead:

-- Tony

Oct 16, 2012 at 7:22 AM

Hi Tony-

  Thanks for the tips.  I've tried them but unfortunately still no luck.  I'm starting to think that I have a corrupted profile and I might have it rebuilt tomorrow.  I'll post back whatever I find out.


Oct 16, 2012 at 4:42 PM


That's a distinct possibility, one I saw mentioned in several posts.

-- Tony

Oct 16, 2012 at 5:31 PM

Hi Tony-

   So I ended up recreating my profile and that solved the problem.  Now I can successfully install a ClickOnce application.  On a Windows 7 box, recreating a profile is pretty straightforward as follows:

- Create a separate account that has local admin privileges

- Login with this separate admin-privileges account

- Rename the profile directory for the corrupted user C:\Users\<username> to a different name

- Launch regedit and navigate to:  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

- There should be a bunch of subfolders with labels such as:  S-1-5-18, S-1-5-19, S-1-5-20, S-1-5-21-...

- Ignore the first three directories (that end in 18, 19, 20), click on the folders for the other directories that have the long numeric names

- Find the folder with a ProfileImagePath that has a data value of C:\Users\<username> where <username> is the name of the corrupted user profile

- Export this folder for good merit and then delete it from the registry

- Log back in with the original username and this forces a rebuild of the profile...

- Voila, now one can install ClickOnce applications

I hope this helps others.  Thanks again Tony for your help with this issue.  Now, on to the real fun of diving into NodeXl :-)



Oct 17, 2012 at 12:39 AM

Holy cow, what a hassle!  I'm glad you were able to make it all work.

Thank you for the detailed steps.  I will definitely point to your post when others run into the same unfortunate problem.

-- Tony