clarifying the sociogram

Nov 6, 2008 at 2:56 PM
Hello all,

I have a sociogram that I made from 158 court cases with anywhere from 2-48 participants per case, needless to say the sociogram is a big mess and very difficult read. I was hoping someone could tell me how to clear the graph up to make it legible and interpretable. I attended the workshop and know there were several very useful and informative ways to help readers (and myself) interpret what I created. If someone can give me a run down or detailed way on the different options I have to clear up my sociogram and how to "play" with these options I would greatly appreciate it.

Thanks!

Maureen
Nov 6, 2008 at 3:58 PM
Maureen:

Take a look at How to Improve the Appearance of Dense Graphs and see if that helps.

-- Tony
Nov 9, 2008 at 9:18 PM
I am trying to do some of the suggestions on from that discussion and it is helping, but I have one question about it. Is there a way to apply the colors and other changes without resetting the sociogram. I have moved some clusters in order to make it easier to read, but every time I apply the colors it resets to the confusing layout.

any suggestions?

Thanks

Maureen 
Nov 10, 2008 at 12:49 AM
Maureen:

You can lock any or all the vertices in place.  Locked vertices don't move when you click Read Workbook.

You can lock a vertex by switching to the Vertices worksheet and selecting Yes in the Locked column.  Or select one or more vertices in the graph pane, right-click anywhere in the graph pane, select Edit Vertex Attributes, and select Yes in the Locked drop-down in the Vertex Attributes dialog box.

To select multiple vertices in the graph pane, hold down the Ctrl key as you click them.  Or drag a marquee around a group of vertices to select them all.  Or hold down the Shift key while dragging a marquee to add a group of vertices to the selection.  (Hold down the Alt key key while dragging a marquee to remove a group of vertices from the selection.)

To select all vertices in the graph pane, right-click anywhere in the graph pane and select Select All, Vertices.

-- Tony
Nov 10, 2008 at 1:57 AM
I have tried locking them and everything seems to shrink back to not legible when I click Read Workbook, also when I go back to click on the vertices attributes the lock (along with all the other attributes I set) aren't there anymore, am I doing something wrong?

Thanks

Maureen
Nov 10, 2008 at 5:35 AM
Edited Nov 10, 2008 at 5:44 AM

Maureen:

Sorry to hear you've run into problems.  I don't know of any .NetMap bugs involving vertex locking, so I wonder if you could try a simple experiment:

  1. Create a new, empty .NetMap workbook.
  2. Enter three edges in the Edges worksheet:  (A,B), (B,C), and (C,D).
  3. Click Read Workbook in the graph pane.
  4. Right-click in the graph pane and select Select All, Vertices.
  5. Right-click in the graph pane and select Edit Selected Vertex Attributes.
  6. In the Vertex Attributes dialog, set Locked to Yes (1) and click OK.
  7. Click Read Workbook in the graph pane.

The vertices should not move in step 7.  They don't for me.  Do they for you?

Thanks,
    Tony

Nov 11, 2008 at 8:31 PM
Ok, I got a chance to try this suggestion and they are staying in place now, however all the other settings change- I set the shape, color, and size and then when I click read workbook or lay out again they change from what I set them. I'm not sure if this is a bug or if I did something else wrong.

Thanks!

Maureen
Nov 11, 2008 at 9:42 PM
Do you have the AutoFill Columns feature turned on?  That automatically fills in various columns, overwriting your manual settings.  In the Excel ribbon, go to .NetMap, Graph, AutoFillColumns, and uncheck "Use AutoFill Columns."

-- Tony
Nov 11, 2008 at 9:45 PM
No, I had previously tried playing around with it, I can't figure out how to reset it, but it isn't turned on now
Nov 11, 2008 at 9:49 PM
Is Show Clusters checked in .NetMap, Analysis?  Uncheck it.  Clusters also override manual settings.

-- Tony