NetMap don't run

Oct 18, 2008 at 4:15 PM
Hello all
I have this warning whe i run NetMap

"Customization could not be loaded because the application domain could not be created."

and NetMap don't load completely

How can i fix this problem ?


Oct 18, 2008 at 6:19 PM
Yann:

It sounds like something went wrong while installing .NetMap.  Did the Setup.exe program run without a problem, or did you get some sort of error message?  Also, there should have been a security question the first time you attempted to open the .NetMap template.  Did you answer "yes" to the "do you want to trust this" question?

Try running Setup.exe again and select the "Repair" option.  See if that fixes things.

-- Tony
Oct 19, 2008 at 4:10 PM
Edited Oct 19, 2008 at 4:29 PM
Yes i did the repair trick several times. But that don't fix the problem
I answered "yes" to the security question
The setup just install/unistall the NetMap template
The installer installed much more things. How can i uninstall them to start a fresh install again ?

EDIT
Some fresh news : i have a new error message
Installing Offcie Customisation

Name:
From: file:///C:/Users/Yann Leroux/Downloads/Microsoft.NetMap.ExcelTemplate.vsto

An error occured during customization install




Oct 19, 2008 at 7:34 PM

Yann:

That last error message may be useful.  It's telling me that Excel is looking for a part of the .NetMap template in what is probably the wrong place.

The Microsoft.NetMap.ExcelTemplate.vsto file is put in "C:\Program Files\Microsoft Research\Microsoft .NetMap Excel Template" by default.  You can change the default and the setup should still work fine, but I need to know whether you actually changed it before I give you more advice.

Question: When you ran Setup.exe, did you change the folder on the "Select Installation Folder" screen from this:

C:\Program Files\Microsoft Research\Microsoft .NetMap Excel Template\

to this:

C:\Users\Yann Leroux\Downloads

-- Tony

Oct 21, 2008 at 10:23 PM
No i did not change the installation folder

I uninstalled and re-installed Office
Sounds that was not a good idea. I have another sort of error message when i run the setup of .NetMap : error 1001 could not create a persistance object for the specified file
Am i cursed ? :-)


Oct 22, 2008 at 12:46 AM
Things are getting complicated here.  I'm going to bypass the latest issue for now and reply to your Sunday question.

The error message referring to a file in your C:\Users\Yann Leroux\Downloads folder makes me wonder if something went wrong when you unzipped the Zip file from our Web site.  Once you unzip the Zip file and run the Setup program it contains, that folder is never used again, and yet it showed up in an error message when you tried to run the template.  That shouldn't happen.

So let's start from scratch, and be sure to follow these instructions exactly:

1. If .NetMap is still installed, uninstall it via Control Panel, Programs and Features (Vista) or Control Panel, Add/Remove Programs (Windows XP).  It shows up as "Microsoft .NetMap Excel Template."

2. Download NetMap_1.0.1.57.zip from our site again, and put it in an empty, temporary folder you've created somewhere, like C:\TemporaryNetMap.  Don't put it in your Downloads folder.

3. In Windows Explorer, right-click the NetMap_1.0.1.57.zip file and select Extract All.  Accept the default destination folder (C:\TemporaryNetMap\NetMap_1.0.1.57), and check the "Show extracted files when complete" checkbox.

4. Click the Extract button.

5. When the extraction is complete (it's very fast) and the C:\TemporaryNetMap\NetMap_1.0.1.57 folder opens, double-click Setup.exe and accept the default "Select Installation Folder," which is likely "C:\Program Files\Microsoft Research\Microsoft .NetMap Excel Template\".

6.  Assuming the setup is successful and you get the "Installation Complete" screen, try using the template.  In the Windows Start menu, click "All Programs" (Vista) or "Programs" (XP), then "Microsoft .NetMap," then "Excel Template."

Please let me know what happens.

-- Tony
Oct 22, 2008 at 11:43 AM
Hello Tony
Thank your for the time and the support you give to my problem
I am still stuck with the sme error : error 1001 could not create a persistance object for the specified file
Oct 22, 2008 at 5:25 PM
Edited Oct 22, 2008 at 5:27 PM
Yann:

Here are the steps I would recommend.  All except step 1 comprise a "fresh install" of .NetMap.

1. Update Office.  You uninstalled and reinstalled Office, so you lost all the Office updates that have been released since 2007.  In Vista, use Control Panel, Windows Update to get all Office updates.

2. Update Windows Installer.  Download WindowsInstaller-KB893803-v2-x86.exe from here and run it:

http://www.microsoft.com/downloads/details.aspx?FamilyID=889482FC-5F56-4A38-B838-DE776FD4138C&displaylang=en

3. Update the Microsoft Office 2007 Primary Interop Assemblies.  Download PrimaryInteropAssembly.exe from here and run it:

http://www.microsoft.com/downloads/details.aspx?FamilyID=59daebaa-bed4-4282-a28c-b864d8bfa513&displaylang=en

4. Update the Microsoft Visual Studio Tools for the Office System 3.0 Runtime Service Pack 1.  Download vstor30sp1-KB949258-x86.exe from here and run it:

http://www.microsoft.com/downloads/details.aspx?FamilyID=D8EB4921-891A-4B5E-973F-0B96E6CCF376&displaylang=en

5. Run the .NetMap Setup.exe.

-- Tony
Oct 23, 2008 at 11:23 AM
I have done all the installation processs

1. Update Office.
Succes
2. Update Windows Installer
Failed. "Insuffisant disk space" I have 70 Go left !

3. Update the Microsoft Office 2007 Primary Interop Assemblies
Success

4. Update the Microsoft Visual Studio Tools for the Office System 3.0 Runtime Service Pack 1.
Succes

5. Run the .NetMap Setup.exe.
Succes

So, i finnally  installed NetMap !.
Unfortunately, the install is not complete and i have the mesage
"Customization could not be loaded because the application domain could not be created." again
At the first run, Excel asked me if i wanted to install new stuff. I said yes.
 
But i am satisfied : that a step toward success :-)

It seems that NetMap is installed but Excel don't find the template. Is it correct ?

Oct 27, 2008 at 5:12 PM
I've forwarded this issue to a group within Microsoft that might be able to help diagnose the problem on your machine.  I'll post here again when I learn more.

-- Tony
Oct 28, 2008 at 5:23 PM
Yann:

When you attempt to open the .NetMap template and get an error message, there should be a button in the error dialog box called "Details>>".  Please click that button, copy the "Error Details", and post them here.

Thanks,
    Tony
Nov 16, 2008 at 7:34 PM
Thank you for your support Tony !
I have some good news : i finally manage to install and run NetMap properly.
I have uninstalled Office, cleaned the registy, reboot, installed Office, the Visual Basic tools and the Primery Interop Assemblies
Reboot. Ran MS Update. Reboot
Holly Binaries ! I can now play with NetMap !



Nov 17, 2008 at 4:15 AM
That's good news, Yann.  I'm sorry you had to go through so much trouble, but it sounds like things are fixed now.

Thanks for letting us know!

-- Tony