Not able to authorize Twitter, access token wasn't sent?

May 23, 2012 at 8:48 PM

I'm trying to authorize NodeXL to access my Twitter account, but it's not working.

 

I click on "I have a Twitter account, but have not yet authorized..." and it takes me to a page that says Authorize NodeXL to use your account. I click yes, it gives me a number, and when I copy and paste that into the PIN number spot in NodeXL, it comes back saying a problem has occured trying to authorize NodeXL, and that an acces token wasn't sent by Twitter.

 

Anyone else experiencing this problem?

Coordinator
May 23, 2012 at 10:20 PM

This may be related to use of an older version of NodeXL.  Can I ask you which version you are running?

Thanks!

Marc

May 23, 2012 at 10:54 PM

Version 1.0.1.210

May 24, 2012 at 1:31 AM

Try this:

1. Select the "I don't have a Twitter account..." option.  Does that work?

2. If that works, select the "I have a Twitter account, but have not yet authorized..." option.  What happens now?

(I don't have NodeXL in front of me, so the option names here aren't exact.)

-- Tony

May 24, 2012 at 1:33 AM

And if it doesn't work, please copy the entire error message here if possible.  You can usually press Control-C to copy a NodeXL error message to the Windows Clipboard.

-- Tony

May 24, 2012 at 2:58 PM

Ended up being a problem with my Twitter account some how. I recently created a new account and don't have much activity on it yet. I authorized it through my old account, and everything is working just fine now. I wonder if there if Twitter has some sort of requirements or something before you can access the data.

 

Thanks for the help though! Keep up the good work!

May 25, 2012 at 1:23 AM

Thanks for letting me know.

-- Tony

Jul 4, 2012 at 2:08 PM

HI,

i'm having the same problem - but can't work it out. 

i just updated my nodexl version to 1.0.1.215 and ask for a user (@comitato13feb) with both people following and followed by the user, 1,5 degree, follow, reply, mention.

as i just updated the version, i had to re-authorize nodexl to access my twitter account, i am taken to the authorization page, allow the application (it does show as an allowed app in my profile setting page), get a pin, write the pin into the blank space in nodexl and get the following message:

A problem occurred while attempting to authorize NodeXL ti use your twitter account, Details: As access token wasn't send by Twitter.

if i try with "i do not have a twitter account", the search for data begins with no problems, but it is a network with some 2300 users so it might take forever if i don't use my account..

what shall i do? could it be that it is because i am working while connected on my university network? there is no particular firewall that i am aware of but i am going to double check... and will let you know.

thanks in advance for all your help

elena

Jul 4, 2012 at 4:59 PM

Elena:

First, you do not have to reauthorize NodeXL to access your Twitter account when you update NodeXL with a new version.  I'm not sure why this problem is occurring for you, but I don't think it's related to the update.

Have you tried the "I have a Twitter account, but I have not yet authorized NodeXL to use my account..." option since you successfully ran with the "I don't have a Twitter account" option?  Try it again, and if it doesn't work, try it again later today.  Offhand, it sounds like a temporary problem on Twitter's end, not NodeXL's end.

-- Tony

Jul 4, 2012 at 5:09 PM
Tony,

thanks a lot for the prompt reply.

I have tried several time with no success - i don't really understand what is happening.
nodexl is authorized so everything should be set, at least as in principle. however, my nodexl has the account-option always disactivated (that is why i talked about a re-authorization). if i do the procedure than it tells me the token is not sent by twitter, but it really might be a problem on twitter's side.

With the "I don't have an account" i could get a network of ca. 3400 nodes (it should me more than 5000, i made a mistake before in typing). so apparently there is a problem with the size of the network i want to download.
i'll try again tomorrow - if anything comes up to your mind in the meantime..
thanks again
elena
Jul 10, 2012 at 7:33 AM

Hi all,

so apparently a proxy in my university network is what prevents the import: at home, under my private network, the new nodexl version allows me to work with my account... i have no idea if nodexl can be set on a specific proxy, can it be? do you think that the proxy presence can be the reason why i can't access with my twitter account?

yet, even at home where i don't have the "proxy problem", maybe for the size of the network i am trying to map (followers of the organizations i am monitoring and follow relationships amongst them), i never get the whole thing and i receive a message that says "part of the network was downloaded - do you want to import it". i always check out how many nodes are mapped and last time i tried, after 13 hours, i got 4176 over 4178 - which is not bad at all. it is not a real issue if i lose 2 followers, hopefully i can discover who they are comparing the list on Twitter and the vertices sheet in my file (so i'm not sure i am losing some big media group or a political party.. or a vertex that needs to be there). even if i can't complain of the result and i might decide to use the network as it is, i was wondering if you have any suggestions on how i can overcome this problem. as the network i am looking at is not so dynamic, do you think that if i limit to 1000 people and repeat the download over and over again i can get to the whole thing? I'm not sure this could be the best option: what if i continue to map the same 1000 users or, say i find just 10 or less new users for each download i make?

moreover, if i stay with the network i have, as the nodexl details message explains, it can't be said how much of the network is not traced: despite i seem to lose only 2 nodes, how can i know if possible edges amongst them are all traced? in other words, if a vertex is present in the vertices list, all edges in which it is included are also present (because maybe nodexl traces down immediately the edges after it identifies a node) or this is not so sure (maybe because nodexl tracks down all nodes and then the edges)? 

apologies for the always incredible amount of questions i am able to put on the table and thank you so much for your help

elena

 

Jul 11, 2012 at 12:07 AM
Edited Jul 11, 2012 at 12:36 AM

Elena:

On the account/proxy issue:

NodeXL automatically works with whatever proxy server is in use.  It does in fact seem to work on your university's network, provided that you don't try to do the Twitter authorization step.   I do not know why the Twitter authorization step is being blocked by your university's proxy server.

So let's try to work around it.  The authorization step worked fine for you at home.  You normally wouldn't know or care about this, but NodeXL stored the authorization information in a file in your personal profile folder on your home computer.  NodeXL looks for this file every time you ask for a Twitter network, which saves you the trouble of having to authorize again and again.  If you copy that file from your home computer to your work computer, you ought to be able to fool NodeXL into thinking that you did the authorization at work.

So try this.  I assume here that you have either Windows 7 or Vista in both locations.

1. In Windows Explorer on your home computer, navigate to the folder that is named something like the following.  The "Elena" part needs to be replaced with whatever name you use for your Windows account at home.

    C:\Users\Elena\AppData\Local\MicrosoftResearch\NodeXLExcel2007Template

2. In that folder you'll find a file called TwitterAccessToken.txt.  Copy that file to a thumbdrive, or email it to yourself at work.

3. Go to work.

4. In Windows Explorer on your work computer, navigate to the folder that is named something like the following.  Again, you'll need to replace the "ElenaAtWork" part with your real account name at work.

    C:\Users\ElenaAtWork\AppData\Local

5. Create a MicrosoftResearch subfolder in that folder, and a NodeXLExcel2007Template subfolder in that subfolder.  These subfolder names must be spelled exactly as indicated.  No spaces!

6. Copy the TwitterAccessToken.txt file from home into the NodeXLExcel2007Template subfolder.

7. Try to import a Twitter network in NodeXL.  If all went well, the "I have a Twitter account, and I have authorized..." option in the dialog box should be automatically checked, because NodeXL now finds the authorization information in the file you copied over.

I tried this trick on two computers here and it worked fine.  However, I do not use a proxy server, so I can't guarantee that your university's network won't cause further problems.  But it's worth a try.

-- Tony

Jul 11, 2012 at 12:34 AM
Edited Jul 11, 2012 at 12:37 AM

Elena:

On the incomplete network issue:

Because there are thousands of Twitter requests that NodeXL must make to assemble a network and there are so many things that can go wrong during the process (Twitter server glitches, short network outages, and so on), there is no way to guarantee that you'll always get the entire network.  NodeXL does its best to work around a failed request, namely by pausing, retrying the request several times, skipping the request after repeated failures, and reporting the failure at the end.

If only two out of 4,178 requests failed in your case, that's actually not a bad ratio, but there is no denying that you don't have the complete network.

You cannot ask for a thousand users and then another thousand, hoping that you'll get the next thousand.  You won't; you'll keep getting the same thousand.

Also, NodeXL gets the vertices first, and then connects the edges.  So if the failed request was for a vertex, you may be missing some edges as well.

When you get a "Partial Network" message, there is a Details link in the dialog box.  The details tell you about the most recent failure.  If you want to post those details next time, I can see if I can at least shed some light on the nature of the failure.

-- Tony

Jul 11, 2012 at 6:53 AM
Tony,

thanks a lot for both replies - i will certainly try the trick with the token and will redo the twitter network so i can post the message of partial network. i will try to get back to you asap but it might take some days as i'm about to leave for some days.

just one detail: when you say

Also, NodeXL gets the vertices first, and then connects the edges. So if the failed request was for a vertex, you may be missing some edges as well.

does it means that for the vertices that i have i also have all edges *amongst them*?

thanks
elena
Jul 11, 2012 at 6:02 PM
Edited Jul 11, 2012 at 6:09 PM

Elena:

I would need to know your settings in the Import from Twitter User's Network dialog box before I could answer that.  NodeXL asks Twitter for different information at different times, depending on what you've asked for.

-- Tony

Jul 11, 2012 at 6:13 PM
Ok, so for the best network I had it was:

  • person following the user
  • followed/following relationships
  • 1,5 level
  • add a latest tweet column
i could easily drop the tweet colum if that "save" some energy for the data retrieval.
Initially i was doing all types of people and all types of relations but it never got to a complete network ... so i decided to split followers of the organization and people followed by the organization in 2 different networks as i can work with them separately. i always have all data about the almost 200 people followed by the organization (relatively few, indeed) and moved on to trace the network of organization's followers with the settings above.

thanks a lot for your extreme patience
elena

Jul 11, 2012 at 11:38 PM

Elena:

When you request a 1.5-level network, NodeXL first gets the people following the user, then connects those followers to the user with edges, then requests more information about the followers to determine whether additional edges need to be added among the followers.  So to your original question, "does it means that for the vertices that i have i also have all edges *amongst them*", the answer is no.  If the failed request might have connected one follower to another, then there might be a missing edge.

All options that take more of what you call "energy" (I like that!) are marked with "slower" in the Import from Twitter dialog boxes.  Adding a Tweet column is not one of those; the tweets come for free.

-- Tony

Jul 12, 2012 at 4:50 AM
Tony,

thanks a lot! will keep you posted on the next steps and will come back to you with updates on the token and the partial import (going home today from university so will be able to try).

ciao!
elena