unable to filter

Feb 3, 2012 at 11:54 AM

Hello, I have been trying all the options to solve this probably simple problem, but I can't make it!

 

I have a group of organizations from which I only want to focus in a few so I have given them a different color. So then I filter on the spreadshit in order to see only the names of the one with the selected color but I can't do this on the graph. Whenever I go and press refresh graph, all e vertices are still shown! I can't get rid of the other ones in the graph.

 

Any ideas?

 

Thanks!

Clara

Feb 3, 2012 at 4:33 PM

Clara:

Filtering the Vertices worksheet using Excel's filtering features won't work in NodeXL.  That's because the filtered vertices are still part of some edges in the Edges worksheet, and so NodeXL will continue to show all the vertices and their edges in the graph pane when you refresh the graph.

But all is not lost.  To get rid of the vertices and their edges in the graph pane, set the vertices' "Visibility" cells on the Vertices worksheet to "Skip."  For more information about what the "Visibility" column does, hover your mouse over the "Visibility" column header.  I'll paste the pop-up message after my signature.

-- Tony

 

Show if in an Edge
Show the vertex when the graph is refreshed if it is part of an edge.  Otherwise, ignore the vertex row.  This is the default.

Skip
Skip the vertex row and any edge rows that use the vertex.

Hide
If the vertex is part of an edge, use it when laying out the graph but then hide it.  Otherwise, ignore the vertex row.

Show
Show the vertex regardless of whether it is part of an edge.

Formulas

If you are using Excel formulas to compute the visibilities, you may find it helpful to use the numerical options instead of text:

1 = Show if in an Edge
0 = Skip
2 = Hide
4 = Show

Pasting

If you want to paste values into this column, do not use the standard Paste command (Ctrl-V).  The standard Paste command removes the drop-down lists from the column.  Instead, use Home, Paste, Paste Values in the Excel Ribbon.