Error 1001:

Nov 29, 2011 at 9:15 AM

Hi all,

I've had a similar issue to this thread: http://nodexl.codeplex.com/discussions/264158

But I'm running on a 32 bit version of Windows XP, trying to install for Office 2010, I'm not completely an admin on my machine (I sort of am? I'm not entirely sure) and I don't have a 9.0 folder as mentioned in that thread, only a 10.0 one. The exact error I get from setup.exe is:

Prerequisite check for system component Visual Studio Tools for the Office system 3.0 Runtime Service Pack 1 failed with the following error message:"Administrator permissions are required to install the Visual Studio Tools for the Office system 3.0 Runtime Service Pack 1. Contact your administrator."

Running Dnrd.msi gets closer but ultimately returns 1001 saying Visual Studio Tools for office installer not found.

 

I've tried downloading it manually from their site but there's so many versions I've probably tried the wrong one! It still fails as I'm 'not an admin', though. Is there any way around this?

 

Thanks in advance!

Nov 30, 2011 at 12:28 AM

Dan:

The correct version of the "Microsoft Visual Studio Tools for the Microsoft Office System (version 3.0 Runtime) Service Pack 1 (x86)" is here (and how's that for a catchy name?):

http://www.microsoft.com/download/en/details.aspx?id=1132

If you get a message saying that you don't have permission to install the tools, then it probably means that someone has restricted what you can do on your computer.  Does the computer belong to a corporation or school?  Do you have an IT department that can install the tools for you?

-- Tony

Nov 30, 2011 at 1:36 PM

Thanks very much! It was a combination of that and my IT rights. I spoke to IT, had to go through a different route to install as an admin.

Even then, running setup.exe said it failed as it couldn't download a file; it pointed to the microsoft site for the Visual Studio Tools (normal package, no service pack!) which I downloaded and installed manually; it then couldn't download a second file, which was the one you linked to. Installing that now means it can work perfectly! Thanks for the help.

 

I've been playing with it for a bit now (I'd have posted sooner but was having trouble connecting) - is there any way to change the font size of a vertex label? The option's there for edges, not for vertices, and the tutorial I'm following seems to be for an older version.

Nov 30, 2011 at 3:23 PM

Dan:

Sorry to hear about the hassles you went through to get NodeXL installed.  As you've seen, it requires a few other pieces of software to run, and getting them all working in a "locked down" environment like yours can be a challenge.

NodeXL has two types of vertex labels, and I assume that you are referring to the type that appears as an "annotation" next to the vertices themselves.  To change the font size for those (and I'm talking about version 1.0.1.196 here; the steps are slightly different in earlier versions), do this:

1. Click Graph Options at the top of the graph pane.  If the graph pane is narrow, the Graph Options button will be hidden under a "down arrow" icon.

2. In the Graph Options dialog box, click the Other tab.

3. On the Other tab, click Labels.

4. In the Label Options dialog box, click Font.

The font you select applies to all vertex labels and cannot be changed for individual vertices.

-- Tony

Nov 30, 2011 at 3:47 PM

Excellent! Thanks very much :)