"Illegal characters in path" error from Network Server with Twitter Lists

Nov 19, 2011 at 9:27 PM

Here's the issue: I am using the Network Server to collect Tweets using the Twitter List Network feature. I'm getting the error below. Can anyone help decipher? 

 

A few points of context: 

  • All the file locations exist and have no permission issues.
  • The Twitter list exists (obviously, as there are pages collected)
  • This sort of works when I do it through Excel, but the list of Tweets returned is shorter than I'd expect.
  • If I use the same set-up (computer, XML files, etc.) but change the configuration file to collect from a Twitter search, this error is not thrown.

Thoughts?

Nov 20, 2011 at 11:25 PM

Warren:

It might be complaining about the folder you've specified for where the results should be stored.  Look at the "NetworkFileFolder" entry under "TwitterListNetworkConfiguration."  Does it look like a sensible path?  Try pasting the path into the address bar of Windows Explorer and check whether it works there.

If you can't figure it out, you can post the entire network configuration file and I'll try to track down the problem.

-- Tony

Nov 21, 2011 at 2:39 PM

Once again user error is to blame! I looked through the file again this morning and it did all look fine. The file location - "C:\Temp" - exists, except for some (stupid) reason I had included quotes in the xml file. D'oh. Problem resolved: user error. 

Thanks again for the attentiveness, Tony. I have another set of questions about features, but I'll start a new thread for that.

Nov 21, 2011 at 5:34 PM
Edited Nov 21, 2011 at 5:35 PM

Warren:

Glad you solved it.

We may eventually eliminate the need to edit those ugly XML files when using the Network Server program.  There should be a decent, forgiving dialog box for specifying the network configuration instead.  The XML files were a shortcut we took when there was only one user of the Network Server program, someone who is on our own team.

-- Tony