Problems with Dynamic Filters

Aug 31, 2011 at 2:06 PM
Edited Aug 31, 2011 at 2:16 PM

Hello,

I  am trying to create an undirected graph, the sources are manuskripts and letters. I have a problem with two vertices and the use of Dynamic Filters. When I have created my graph and wanted to use the Filter for e.g. to sort out all vertices with have less than a degree of two (which are a lot), then two vertices dissappear immediately. This are my egocentric actor with an degree about 100 and another who has an degree about 33. Could anybody give me an advice what could be wrong? When I click  Refresh Graph both vertices are appearing again.

This problem exist since I have added some new vertices by hand and not by import.

For any help or tips many thanks!

Aug 31, 2011 at 5:04 PM

Paulsen:

When you added the new vertices by hand, you probably didn't recalculate the vertex degrees, and so the Degree cells for those new vertices are empty.  Then, when you tell Dynamic Filters to show vertices whose Degree is two or greater, it hides the new vertices because they do not have a Degree of two or greater.  In fact, they have no Degree at all.

To fix this problem, you need to recalculate all the Degree cells before using Dynamic Filters.  You do that with NodeXL, Analysis, Graph Metrics in the ribbon.

-- Tony

 

Sep 4, 2011 at 1:22 PM

Dear Tony,

thank you for your answer! I tried ist, but this did not help. I solved the problem with replacing empty cells with "*" through 99. So now I am able to use the Dynamic Filters. Many thanks for your idea!

Sep 4, 2011 at 5:45 PM

Paulsen:

I don't understand why my suggestion didn't work.  The problem is caused by empty cells, and recalculating graph metrics should fill in the empty cells.  Did you check the "Degree" option in the Graph Metrics dialog box?

But in any case, it sounds like you fixed the problem yourself.

-- Tony