Twitter import error

Aug 16, 2011 at 7:17 AM

Hi, there. I'm trying to import a Twitter user network, and am running into an error. The message is that the network cannot be imported because "an item with the same key has already been added." I looked it up on the site here, and saw that that particular error happened in a different circumstance due to a bug that was subsequently fixed. Is there something that I need to be doing differently? Thanks!

Aug 16, 2011 at 4:50 PM

This shouldn't happen, and it's nothing you're doing wrong.

I believe there are more details in the error message.  If I'm correct, please paste all the details here.

Can you tell me all of the settings you're using in the Import from Twitter User's Network dialog box?  That would be the username, the "Add a vertex for each" setting, and so on.  I want to try to get the problem to occur here so I can track it down.

Thanks,
    Tony

Aug 16, 2011 at 5:50 PM

Actually, no--the entire error message is this: "The network couldn't be obtained. Details: [Argument Exception]: An item with the same key has already been added." There's nothing else.

I've tried various settings changes, thinking that that may have been the problem. The only constants were that I only wanted followers (too unwieldy otherwise), and I wanted 2.0 depth. All the other options changed, and I got the error with all of them. New, clean template, old template with clearing data, old template keeping data. All my combos have pulled the same error. The user name is IASPR.

 

Thanks for the help!

kat

Aug 16, 2011 at 7:30 PM
Edited Aug 16, 2011 at 7:37 PM

kat:

This bug will be fixed in version 1.0.1.175 of NodeXL, which will be released in the next couple of days.  In the meantime, you can get things to work in the version you have by entering "iaspr" (all lower case) instead of "IASPR" for the username.

Thank you for reporting this.

-- Tony

Aug 17, 2011 at 4:18 AM

Lovely! Thanks so much--I really appreciate the help. :)

 

kat