Error in importing networks

Jul 11, 2011 at 1:54 PM


I'm having problems when importing networks (graphml, twitter, youtube,etc). 

In the error message I was told to submit the problem here. So, a complete copy of the message goes in the following.

Do you have any idea about what is going wrong ?

I hope it can be useful for future versions! 

Thanks a lot!

Alexandre L. M. Levada

---------------------------Microsoft NodeXL--------------------------

-An unexpected problem occurred.  If it occurs again, please copy the details to the clipboard by typing Ctrl-C, then post the details to


[IndexOutOfRangeException]: O índice estava fora dos limites da matriz.

   em Microsoft.NodeXL.ExcelTemplate.GraphImporter.ImportVertexAttributes(IGraph oSourceGraph, String[] asVertexAttributes, Dictionary`2 oVertexDictionary, ListObject oVertexTable)
   em Microsoft.NodeXL.ExcelTemplate.GraphImporter.ImportVertices(IGraph oSourceGraph, String[] asVertexAttributes, ListObject oVertexTable, Range oVertexNameColumnData, Range oVisibilityColumnData)
   em Microsoft.NodeXL.ExcelTemplate.GraphImporter.ImportGraph(IGraph sourceGraph, String[] edgeAttributes, String[] vertexAttributes, Boolean clearTablesFirst, Workbook destinationNodeXLWorkbook)
   em Microsoft.NodeXL.ExcelTemplate.ThisWorkbook.ImportGraph(IGraph oGraph, String[] oEdgeAttributes, String[] oVertexAttributes)

---------------------------OK   ---------------------------

Jul 11, 2011 at 4:04 PM

Can you please save a NodeXL workbook in which this problem occurs and send me the workbook?  You can't post a file on the CodePlex Discussions tab, but you can do so on the Issue Tracker tab at  Just create a "new item" and attach the workbook file to it.  You don't need to explain anything in the new item; I'll know what it is.

This is a new bug that obviously isn't supposed to happen, and I can't get it to happen on my computer.  It might be some workbook condition that NodeXL doesn't expect.  It might also be related to language (I assume you use Spanish), but I'll look at the workbook first.


Jul 11, 2011 at 5:01 PM

I'll try to do that! However, I don't know if the bug will be visible to you, since after the warning message, if I click on the Ignore button, data is loaded perfectly. I can even visualize the entire network. The only problem seems to be when I want to calculate the metrics such as degree, etc...

By the way, as you said, the problem may be related to language (I'm from Brazil and the language here is Brazilian Portuguese - it has special characters such as ç, à, á, é,...). On the other hand, my Excel is an English version and I don't have this kind of characters in the datasheet.



Jul 11, 2011 at 7:07 PM

Thanks for the workbook, Alexandre.  It enabled me to discover the cause of the bug.

You have an Excel feature called "auto table expansion" turned off, and NodeXL needs it to be turned on to work properly.  To turn it on, do the following:

* Click the round Office Button at the upper-left corner of the Excel window.

* Select Excel Options, Proofing, AutoCorrect Options, AutoFormat As You Type.

* Check "Include new rows and columns in table."

In the next version of NodeXL (, NodeXL will warn you if the feature is turned off and offer to turn it on for you.

Thanks for reporting the bug.

-- Tony

Jul 11, 2011 at 7:14 PM

Thanks for the help!

Surely, it will help me a lot!