error 1001

Jul 6, 2011 at 9:13 PM

I am attempting to install NodeXL excel template on my Windows 7 64 bit machine with office '07.  I get the following error after each attempt "Error 1001: The Visual Studio Tools for Office installer not found."  I am administrator on this computer, I have even tried "run as" administrator, I have attempted to install the previous version, I have restarted the computer to make sure no background office components are running and attempted to install, all with the same result.  I searched for error 1001, but all the other ones had different error strings.

Jul 7, 2011 at 6:01 AM

Please try manually installing the "Microsoft Visual Studio Tools for the Microsoft Office System (version 3.0 Runtime) Service Pack 1 (x86)."  This is a piece of required software that is supposed to be automatically installed with NodeXL, but perhaps something went wrong during its installation.  You can download it from here:

-- Tony

Jul 7, 2011 at 7:46 AM

Unfortunately that didn't work.  I also tried deleting the folder created by the failed install, but I still get the same error.


Jul 7, 2011 at 8:17 AM

The NodeXL setup program is looking for a program called VSTOInstaller.exe.  On a 64-bit English machine, that should be in the folder C:\Program Files (x86)\Common Files\microsoft shared\VSTO\9.0.  Does that folder exist?

Also, when you say "that didn't work," do you mean that 1) the download I pointed you to ran successfully but didn't fix the problem; or 2) the download didn't run successfully?

-- Tony

Jul 7, 2011 at 8:57 AM

Sorry, that wasn't clear.  I successfully downloaded and ran without error the file you pointed me to.  I  then received the same 1001 error when attempting to install the NodeXL template.    The path C:\Program Files (x86)\Common Files\microsoft shared\VSTO\9.0 exists on my PC and VSTOInstaller.exe is present in the 9.0 folder.

Jul 7, 2011 at 5:47 PM
Edited Jul 7, 2011 at 5:47 PM

This is very odd.  The NodeXL setup program asks Windows for the "common files" folder, then appends "Microsoft Shared\VSTO\9.0" to the folder path to find the VSTOInstaller.exe program it needs.  I wonder if something is wrong with what Windows thinks is the "common files" folder on your machine?

Please do the following.  (Pardon the detailed instructions if you already know how to do this.)

1. Open a command window.  In the Windows Start menu, search for cmd and select cmd.exe from the search results.

2. In the command window, type "set CommonProgramFiles(x86)" without quotes, then press Enter.  You'll get a single line of results.

3. Copy the results here.



Jul 7, 2011 at 9:01 PM

Here is the cut and paste from the cmd window

CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files


Jul 7, 2011 at 9:51 PM

I think I found the issue, the installer isn't looking in Program Files (x86).  I copied the 9.0 folder from the x86 path on my computer and created the following path C:\Program Files\Common Files\Microsoft Shared\VSTO\9.0 and the installer worked without issue.


Jul 7, 2011 at 10:17 PM

I spoke to soon.  The installer worked fine, but when opening the "NodeXL excel template" shortcut I get the following error "The customization assembly could not be found or could not be loaded..."  Not sure if this is a security setting as mentioned somewhere else in the forum, or due to the fact that I "tricked" the installer into working on 64 bit machine.



Jul 8, 2011 at 2:27 AM

I am pretty sure this is an incompatibility with my 64 bit install.  The error that popped up in Excel (see below) references the VSTA directory but is looking for it in Program files not the (x86) path where it exists on a 64-bit machine. 

error text:

Microsoft.VisualStudio.Tools.Applications.Runtime.CannotCreateCustomizationDomainException: Customization could not be loaded because the application domain could not be created. ---> System.IO.DirectoryNotFoundException: The given folder "C:\Program Files\Common Files\Microsoft Shared\VSTA\Pipeline" does not exist.


Jul 8, 2011 at 6:22 AM


Is there something unusual about your computer that might cause one or more programs to get mixed up about whether they're running in a 32-bit or 64-bit environment?  Is it a development machine, or has it had beta versions of Windows previously installed on it, or is there anything different you know of regarding your Office version?  NodeXL should work fine on a 64-bit Windows 7 machine with Office 2007.  In fact, that describes the main machine I use all day and NodeXL works fine on it.

In case you're interested in the technical side of the problem: The NodeXL setup program, which is 32-bit, asks Windows for the path to the "common files" folder.  Windows is supposed to answer "C:\Program Files (x86)\Common Files" in your case, thanks to a system called WoW64 that manages how 32-bit programs run within 64-bit Windows.  It seems to actually answer "C:\Program Files\Common Files," which is wrong.  I can't figure out why this is happening.

-- Tony

Jul 8, 2011 at 7:06 AM

I don't think there is anything odd.  I work at a large corporation and it is a rather boring Dell optiplex with Windows 7 Pro installed.  I did have it running in Test Mode because I had some programs with unsigned drivers, but I took it out of test mode as one of the first troubleshooting tests and it didn't help.  For now I have simply copied the VSTA directory to the Program Files path and everything seems to be working.  Just getting my feet wet and fiddling with my Facebook network.


Jul 19, 2011 at 11:21 PM

Was there an agreed upon resolution to this issue? I've just experienced the same problem - and tried the troubleshooting steps and ended up with the same result (have not copied the VSTA directory over to 32 bit Program Files yet...). Thx.


Jul 20, 2011 at 5:23 AM
Edited Jul 20, 2011 at 5:31 AM


I haven't figured out the cause, and because I can't get the problem to occur on any of my computers (and also because something "impossible" is happening), it's tricky to diagnose and fix.

Are you willing to play detective?  I've written a very short program that asks Windows for the path to one of its folders, then copies the information to the clipboard.  If you could do the following on your computer, it might provide me with some helpful clues as to what is going on.

1. Go to the issue "Program for detecting common program files folder" at

2. Download the CheckCommonProgramFilesFolder.exe program from that page.

3. Run the program by double-clicking it in Explorer.  You'll be asked a security question, because the program came from an unknown source.  (I'm the NodeXL programmer, by the way.  I'm a contract software developer for Microsoft Research.)

4. Copy the results here.


Jul 20, 2011 at 5:31 AM

Happened to be sitting at my PC (night shift) when this thread came back to life.  Here is the paste from my clipboard after running CheckCommonProgramFilesFolder.exe  >>

The Common Program Files folder is "C:\Program Files\Common Files."  This message has been copied to the clipboard.



Jul 20, 2011 at 6:31 AM

Thanks, Chris.  I strongly suspect that Laura will get the same results if she runs my test program.

I've posted the problem to a forum for Microsoft developers in the hope that someone will be able to tell me why your computer behaves differently from most others.  I'll post here again if I get some answers.

-- Tony

Forum post:

Jul 20, 2011 at 4:38 PM

I obtained the same result:

The Common Program Files folder is "C:\Program Files (x86)\Common Files."  This message has been copied to the clipboard.

I should add that I'm also using a Dell machine (Adamo laptop) that I don't believe (based on other problems) was configured properly to run Windows 7.

Jul 20, 2011 at 5:33 PM

I assume that logrady and lauraogrady are the same person, namely Laura.

Laura, the results you obtained were not the same as Chris's results, and now I'm wondering if we're all talking about the same problem.  To go back to the beginning, did your NodeXL problem start with the error message "Error 1001: The Visual Studio Tools for Office installer not found"?  I ask because there are several "Error 1001" messages, all with different causes.


Jul 20, 2011 at 5:42 PM

Correct on both.

I misplaced my login credentials yesterday and had to create a new user name (logrady is also lauraogrady).

I now see the difference between the two. My common program files is in the (x86) directory. And I now recall my initial error message from the install was different. I'm now re-installing the latest version of NodeXL on my laptop running Windows 7. Also note that I have the previous version of NodeXL installed so this latest attempt was an install on top of a previous version. Will get back to you soon with exact error msg.


Jul 20, 2011 at 5:51 PM

First error msg:

Error 1001: The installation of the ClickOnce solution failed with an exit code: 400

When I click on "ok" I get second error msg:

Error 1001: An exception occurred during the Rollback phase of the installation. This exception will be ignored and the rollback will continue. However the machine might not fully revert to its initial state after the rollback is complete. --> The savedState dictionary has been corrupted and does not contain the expected values and might have been corrupted.


Jul 21, 2011 at 5:30 AM


The problem you're having is different from Chris's, so I've transferred it to a new discussion.  Please see "Error 1001: The installation of the ClickOnce solution failed with an exit code: 400" at

-- Tony

Jul 23, 2011 at 7:36 PM


There were no useful responses to the question I posted at  I do not know why your computer is doing what it's doing.  Sorry I can't help with this one.

-- Tony

Jul 25, 2011 at 8:44 PM


No problem, it works fine with my workaround of moving all the necessary folders around.  Thanks for your individual attention.