problems installing NodeXL on Vista

May 29, 2010 at 3:50 AM

Whether I try to install the new template from within XL2007 or install from the All Programs menu, I get the same result:  XL loads the file with sheets labeled Edges, Vertices, etc, and gives an error message:

 "Microsoft Office Document Customization

The customization assembley could not be found or could not be loaded.  You can still edit and save the document. Contact the administrator or the author of this document for further assistance" 

There is a "details" button that reveals the following


Name: Microsoft.NodeXL.ExcelTemplate

From: file:///C:/Program Files/Microsoft Research/Microsoft NodeXL Excel Template/Microsoft.NodeXL.ExcelTemplate.vsto


Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))


************** Exception Text **************

System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

   at System.Deployment.Internal.Isolation.IsolationInterop.CreateActContext(CreateActContextParameters& Params)

   at System.Deployment.Internal.Isolation.IsolationInterop.CreateActContext(IDefinitionAppId AppId)

   at System.ActivationContext.CreateFromName(ApplicationIdentity applicationIdentity)

   at System.ActivationContext.CreatePartialActivationContext(ApplicationIdentity identity)

   at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.InstallAddIn()





I've tried reinstalling/repairing the installation. I get the same problem.  I am administrator on this PC.

I've also tried running SETUP using "run as adminstrator"=> same problem


Also double clicking on the 

Microsoft.NodeXL.ExcelTemplate.vsto" files give me the same result.

Thanks! John Rodgers

May 29, 2010 at 3:12 PM


  I found the directions at 


which deals with a similar problem.   Turns out that though the account I use on this machine has me listed as administrator that there is another account also listed as administrator, and the two do not have equal access. 

I WAS able to install and run NodeXL on the other admin account.  I then copied the template to my "user" desktop as directed, then went back to the user account and double-clicked on the vsto file; this gives me the same error having to dow with customization.


May 29, 2010 at 5:02 PM


Seems to be something peculiarly wrong with my user account, because another user account on the same computer can install without problem. 



May 29, 2010 at 5:47 PM
Edited May 29, 2010 at 5:48 PM


The problem with the account that fails involves some sort of restriction that has been applied to the account. (That's the "Access is denied" part.) Do you know if you or someone else locked down the account in any way, either directly on your computer or remotely by an IT administrator?

These restricted access problems can be difficult to diagnose. If it's possible, it might be far easier to just use the third account, the one that works.

-- Tony

May 29, 2010 at 11:17 PM

I was able to get it to work in my account by turning off the User Account Control and rebooting.  However, if I turned it back on again and rebooted to enable UAC, then I can no longer run NodeXL.

    I'll just use another user account and let this one go....

 John Rogers